T'eyla Minh (teylaminh) wrote,
T'eyla Minh
teylaminh

  • Mood:

Grr.

However, I have just discovered that my website doesn't work.  The account has apparently expired, even though I paid them in full about two weeks ago and everything on my account at the site is telling me I'm paid up.  I'm hoping it's just a glitch.  I'm pretty sure it was working the other day because my mood icons were all showing up.  Meh. I mean, I have all the main pages saved to my hard drive, but that's beside the point, rather.

Edit 19.58: Automated response came through telling me to visit the payments page. Which I did. AND IT SAYS I'VE PAID FOR EVERYTHING! I have the email from them to say "payment received", the money has left my account, the invoice also says "PAID" on it. Someone made a mistake. I wonder how many more times I get to reply to the automated response before someone actually pays attention...?

Edit 20.33: Got an actual response; apparently I registered the domain with my old another.com email address and then the hosting with the new one. Except my another.com account has expired and I can't log in with it (and can't get the password emailed to me, either, because I can't access it) so now I'm sort of stuck. But at least their helping people are actually helpful.

Edit 21.38: Sorted! The very nice helpdesk person moved the domain account to the current email address so it's now all paid for. Panic over. I'm definitely going to leave them some nice feedback. :)
Tags: annoyances: internet, website
Subscribe
  • Post a new comment

    Error

    Comments allowed for friends only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 5 comments